ВНИМАНИЕ! ОСТЕРЕГАЙТЕСЬ МОШЕННИКОВ!
Помните, что все браузеры Opera АБСОЛЮТНО БЕСПЛАТНЫ.
Загружайте новые версии ТОЛЬКО С ОФИЦИАЛЬНОГО САЙТА или с ресурсов, которым ДОВЕРЯЕТЕ!


Предыдущее | Следующее | Архив форума | myOpera.net | Поиск
появились проблемы с youtube 123qwert  01/30/17 08:50 AM

Здравствуйте форумчане.

Операционная система linux федора версия 11

Опера версия 12.15

Раньше видео показывалось нормально. Полгода назад видео на youtube стало тормозить. Показ видео идёт следующим образом:

раньше когда всё было нормально - видео в полосе прокрутки потихоньку загружается и воспроизводится, при хорошем интернете загрузка опережает показ и всё идёт нормально,

сейчас когда тормозит - видео загружается, идёт показ, потом через несколько секунд в полосе прокрутки показывает, что всё что загружено исчезло до самого момента показа и в это время видео останавливается на пол секунды, потом опять идёт загрузка, продолжается показ и через несколько секунд всё повторяется. При просмотре получаются как бы заикания.

На других сайтах видео идёт нормально.

Эта проблема появилась только с youtube где то пол года назад.

На другом железе с точно такой же программной конфигурацией картина та же.

Оперу и систему я обновлять категорически не хочу.
Оперу потому, что последние версии оперы - это уже совсем другая программа, а я привык к старой.
Систему потому что у меня всё настроено и меня всё в системе устраивает, по поводу безопасности, то же всё настроено - лишние сервисы не запущены, критические моменты по безопасности я обновляю.

Есть ещё одна причина по которой не хотелось бы обновлять оперу.
Недавно поставил на флешку образ linux proteus, и на него поставил оперу из репозитория стандартным менеджером пакетов. Так вот по умолчанию он установил оперу версии 12.16, а у меня 12.15.
И на linux proteus в опере версии 12.16 youtube работал отлично. Не было сброса загрузки видео, всё работало как и раньше.
Я начал разбираться, думал дело в флешплеере.
Командой:
strace -vt -e trace=open -o /opera.txt opera
посмотрел какие файлы она использует при загрузке и показе видео с youtube

использует следующий флешплеер:

/usr/lib/mozilla/plugins/libflashplayer.so
это ссылка на файл:
/usr/lib/flash-plugin/libflashplayer.so

Скинул с linux proteus этот флешплеер, практически все папки с оперой, с её настройками и бинарниками. Проверил по библиотекам - всё нормально. Опера запустилась но при показе видео с youtube всё осталось по прежнему с заиканиями. Мало того, я удалил libfleshplayer.so и опера запустилась и показывала видео с youtube но с заиканиями и с сбросом загрузки.

Возникает вопрос как без libflashplayer.so опера может показывать видео, может для этого она использует другие плагины, если да то какие, как узнать?

За помощь заранее благодарен!


Re: появились проблемы с youtube 123qwert  01/30/17 09:22 AM

При удалении libflashplayer.so видео с сайтов не воспроизводится - пишет нет плагина, а с youtube воспроизводится. По видимому видео с youtube воспроизводится другим плагином, не libflashplayer.so
Если кто знает подскажите каким?

Re: появились проблемы с youtube 123qwert  02/05/17 03:44 PM

Проблему решил.
Не знаю какие плагины опера использовала раньше когда всё работало.
Но сейчас она по видимому для проигрывания видео с youtube.com использует библиотеку /usr/lib/libgstvideo-0.10.so.0.16.0
скопировал эту библиотеку в другое место и теперь всё нормально.
Теперь по видимому опера при проигрывании видео с youtube.com использует библиотеки в папке /usr/lib/mozilla или /usr/lib/flash-plugin
Библиотека /usr/lib/libgstvideo-0.10.so.0.16.0 нужна для проигрывателя видео totem, поэтому при запуске этого проигрывателя библиотеку надо возвращать на своё место.



MyOpera.net - Home


Rambler's Top100