ВНИМАНИЕ! ОСТЕРЕГАЙТЕСЬ МОШЕННИКОВ!
Помните, что все браузеры Opera АБСОЛЮТНО БЕСПЛАТНЫ.
Загружайте новые версии ТОЛЬКО С ОФИЦИАЛЬНОГО САЙТА или с ресурсов, которым ДОВЕРЯЕТЕ!


Предыдущее | Следующее | Архив форума | myOpera.net | Поиск
Opera 9.02 не устанавливается на RH7.3?! spezialist  09/22/06 10:33 AM

Привет всем!

Люблю оперу, очень, отслеживаю каждый новый апдейт для ASPLinux 7.3 и вот имею при попытке установить 9.02:

# rpm -Uvh --test opera-9.02-20060919.1-static-qt.i386-en.rpm
error: failed dependencies:
libc.so.6(GLIBC_2.3) is needed by opera-9.02-20060919.1
libpthread.so.0(GLIBC_2.3.2) is needed by opera-9.02-20060919.1

Дистрибутив оперы скачан точно для RH7.3 (качал дважды, думал что ошибся). Я этого не могу понять: откуда в RH7.3 возьмется glibc-2.3, если там по жизни был и будет glibc-2.2? Через мой ASPLinux 7.3 прошло уже с десяток версий оперы, но такой баг впервые.

Заранее благодарю за поддержку.


Re: Opera 9.02 не устанавливается на RH7.3?! Ilya  09/22/06 12:39 PM

Попробуй скачать не shared, а static версию.

Re: Opera 9.02 не устанавливается на RH7.3?! spezialist  09/22/06 12:48 PM

Читайте внимательнее мой предыдущий пост :-).


Re: Opera 9.02 не устанавливается на RH7.3?! Ilya  09/22/06 05:51 PM

А, прошу прощения. Торопился. Может, баг новой версии Opera? В оперном форуме больше никто не спрашивал?

Re: Opera 9.02 не устанавливается на RH7.3?! 9A4172  09/24/06 08:10 AM

А если попробовать поставить с --nodeps? Если это действительно статическая сборка, то, может, они просто в SPEC-файле зависимости не убрали.

Re: Opera 9.02 не устанавливается на RH7.3?! spezialist  09/24/06 06:47 PM

Ну это первое что мне пришло в голову: а вдруг простая ошибка? Но ничего просто не бывает, при запуске таким образом установленной оперы имеем:
$ opera
/usr/lib/opera/9.02-20060919.1/opera: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /usr/lib/opera/9.02-20060919.1/opera)
/usr/lib/opera/9.02-20060919.1/opera: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /usr/lib/opera/9.02-20060919.1/opera)

Т.е. явно надо glibc-2.3! И насколько я вижу на основном сайте оперы эту версию под RH7.3 так и не перекомпилили. Куда обращаться в таком случае? Ведь это явная ошибка! Кто-то уже имел опыт общения с разработчиками?

Заранее благодарю за поддержку.


Re: Opera 9.02 не устанавливается на RH7.3?! Ilya  09/25/06 01:35 PM

Обращаться - к разработчикам, в баг-репорт.
_https://bugs.opera.com/wizard/_


MyOpera.net - Home


Rambler's Top100