ВНИМАНИЕ! ОСТЕРЕГАЙТЕСЬ МОШЕННИКОВ!
Помните, что все браузеры Opera АБСОЛЮТНО БЕСПЛАТНЫ.
Загружайте новые версии ТОЛЬКО С ОФИЦИАЛЬНОГО САЙТА или с ресурсов, которым ДОВЕРЯЕТЕ!


Предыдущее | Следующее | Архив форума | myOpera.net | Поиск
флеш показывается Denn  09/07/05 05:12 PM

Почему при отключенных картинках на некоторыъ сайтах флеш всё равно кажется?

Re: флеш показывается Mailov  09/07/05 08:08 PM

потому что флэш - это плагин

Re: флеш показывается Пилигрим  09/09/05 10:56 AM

Кстати, как оказалось, антифлаш режет далеко не все, да при этом еще и извращает основной текст страницы

Re: флеш показывается Denn  09/11/05 03:52 PM

подскажите гда взять антифлеш?

Re: флеш показывается Stinger  09/11/05 04:19 PM

Denn
В ответ на:
подскажите гда взять антифлеш?


Хорошо работает комбинация Userjs и CSS. Флэшки заменяются черным квадратом и не загружаются. При клике по квадрату - флэшка загружается и проигрывается.

Скачать CSS:
_//opera.nsk.su/?show=css&id=17_
(Подключать точно также как и no_flash.css. См. FAQ от Мангуста)

Скачать User JS:
_//opera.nsk.su/?show=ujs&id=1_
(Подключать точно также как и любой UserJS-скрипт)

Re: флеш показывается Skinmax  09/18/05 07:16 PM

А не скажете, как установить User JS? Много чего пересмотрел, но так и не разобрался (если можно, то для этого случая). Если без использования JS использовать no_flash.css, то как и в решении от Мангуста, флеш режется, но CSS самого сайта, т.е. вся разметка, все цветовое оформление и т.д. исчезает....

Re: флеш показывается Stinger  09/18/05 08:28 PM

Skinmax
В ответ на:
А не скажете, как установить User JS? Много чего пересмотрел, но так и не разобрался (если можно, то для этого случая). Если без использования JS использовать no_flash.css, то как и в решении от Мангуста, флеш режется, но CSS самого сайта, т.е. вся разметка, все цветовое оформление и т.д. исчезает....


Очень просто. Нужно создать папку с произвольным именем в каталоге Opera, например можно назвать папку простым и понятным словом UserJS. Затем в эту папку кидается файлик no_flash.js. Далее в настройках Оперы, на вкладке "Дополнительно" (Advanced), "Содержимое" (Content), "Настроить JavaScript..." (JavaScript Options), в опции "Мои файлы JavaScript" (My JavaScript files) нужно указать полный путь к ранее созданной папке UserJS (пример: C:\Program Files\Opera8\UserJS ). Сохранить настройки.

Чтобы связка работала, необходимо чтобы пользовательский файл CSS (no_flash_ujs.css) был корректно подключен и активирован.

Re: флеш показывается Skinmax  09/20/05 04:56 PM

Спасибо, буду знать. Это помогло. Осталась проблема с CSS, но я лучше создам другую тему....

Re: флеш показывается Denn  09/22/05 04:08 PM

а в версии 7.10 я не нашел где настроить JS
в ней нельзя это сделать?

Re: флеш показывается Stinger  09/22/05 05:13 PM

Denn
В ответ на:
а в версии 7.10 я не нашел где настроить JS
в ней нельзя это сделать?


В седьмой Опере этого нет. Поддержка UserJS появилась только в Opera 8.xx.

Re: флеш показывается ma4o  10/03/05 07:10 PM

Доброго всем времени суток только что поставил
Оперу 8.5 rus проблема в том что ни как не могу настроить резку флеша
поставил no_flash.css как написано у мангуста не работает
флеш как шла так иидет и ещё какие то странные полосы появляются
ps если честно я перепробовал много броузеров ( последний Firefox
) и ни в одном с резкой флеша проблем не было


Re: флеш показывается Stinger  10/03/05 10:04 PM

ma4o

FlashBlock для Opera

1. Установка CSS no_flash_ujs.css (http://opera.nsk.su/?show=css&id=17)

Скачать CSS-файл и закинуть его в \Opera\styles\user\
Закрыть Оперу.
Отредактировать \Opera\OperaDef6.ini (это в windows-версии так файл называется, в линукс-версии название другое), в секцию [Local CSS Files] добавить:
Name 12=FLASHBLOCK
File 12=С:\Program Files\Opera850\styles\user\no_flash_ujs.css
(Вместо "12", если потребуется, подставьте другое число, в порядке следования.)
(Вместо "С:\Program Files\Opera850\" введите ваш путь до каталога Opera)

Запустите Оперу. Переходите в Настройки (Alt+P) - Дополнительно - Содержимое - Настроить стили
В колонке: "Режим пользователя" включите все галки
Опцию "Режим по умолчанию" нужно выставить как: "Режим пользователя"
Сохранить изменения ('ОК')

Затем нужно переключится в пользовательский режим стиля страницы (Вид -> Стиль -> Режим пользователя) и отметить галочкой "Flashblock"

2. Установка no_flash.js (http://opera.nsk.su/?show=ujs&id=1)

Создать внутри папки Opera подкаталог с произвольным именем, например назвать его "UserJS"
Скачать файл no_flash.js и закинуть его в папку Opera\UserJS
В Опере зайти в Настройки - Дополнительно - Содержимое - Настроить JavaScript. В опции "Мои файлы JavaScript" прописать полный путь до каталога UserJs, например:
C:\Program Files\Opera850\UserJs\
Сохранить изменения ('ОК')

Вот скриншот того, как это должно должно выглядеть, если все правильно сделано: _//img400.imageshack.us/img400/4530/flashblock4zj.png_

P.S: Если потребуется подгрузить сразу все флэшки на странице, просто отключите стиль "FlashBlock" через кнопку стилей.

Re: флеш показывается ma4o  10/04/05 10:10 AM

to Stinger большое спасибо всё ок работает ( хотя странно вроде до этого делал то же самое )
единственно что я ещё добавил в файле OperaDef6.ini :
Name 12=Disable Flash
Translated name 12=100000
File 12=C:\Program Files\Opera\styles\user\no_flash_ujs.css

а в файл ru.lng строку :
100000="Блокировка флеш"
чтоб в меню по русски отображалось
ps флеш конечно резать стала но далеко не везде =(

Re: флеш показывается Stinger  10/05/05 04:08 AM

ma4o
В ответ на:
ps флеш конечно резать стала но далеко не везде =(


У меня очень редко попадаются сайты где флэш не блокируется.

Re: флеш показывается Artiom  10/05/05 08:04 AM

Подключил css файл как написал Stringer, ноновый пункт в Styles не появился. И вообще если переключаться в User Mode все выглядит страшно
Юзаю Opera 8.50 - ставил поверх 8.02

Re: флеш показывается Stinger  10/05/05 10:05 AM

Artiom

В ответ на:
Подключил css файл как написал Stringer, ноновый пункт в Styles не появился. И вообще если переключаться в User Mode все выглядит страшно
Юзаю Opera 8.50 - ставил поверх 8.02


Ты должен был правильно расставить галочки в настройках стилей. Читай внимательнее.


Re: флеш показывается Artiom  10/05/05 11:26 AM

Да нет, все галки поставил. А FLASHBLOCK не вижу

Re: флеш показывается ma4o  10/05/05 06:01 PM

угу у мну тож не появилась пока русификацию не сделал
как написано выше
сделаешь русификацию появится и на русском



Re: флеш показывается Stinger  10/05/05 09:29 PM

Artiom
В ответ на:
Подключил css файл как написал Stringer, ноновый пункт в Styles не появился. И вообще если переключаться в User Mode все выглядит страшно


Это верный признак того, что галки расставленны неправильно. В колонке "Режим пользователя" должны стоять все галки.

В ответ на:
Да нет, все галки поставил. А FLASHBLOCK не вижу


Значит что-то неправильно добавил в operadef6.ini. У меня так прописанно:

Name 13=Flash_Blocker
File 13=C:\Program Files\Opera8\styles\user\no_flash_ujs.css


Под номером 13 потому, что на 12-й позиции у меня вписан собственноручно прикрученный adblocker.css.

ma4o
В ответ на:
угу у мну тож не появилась пока русификацию не сделал
как написано выше
сделаешь русификацию появится и на русском


Без русификации тоже работает.


Re: флеш показывается mav34  10/17/05 07:13 PM

Бред какой-то!
Флеш блокируется нормально(черный квадрат), а пункта FlashBlocker нет
Галки стоят, в файле operadef6.ini 12-м пунктом все как надо+перевод
Где ещё посмотреть?


MyOpera.net - Home


Rambler's Top100